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Revision History
Rev 1.02 – Original Release with the RRC3 Altimeter.
Rev 1.10 – Revised for use with RTx/GPS Telematics System. (Starting on page 9)

LCD Interface
The LCD interface can be used to configure, review flight data on, and perform diagnostics on your altimeter. It’s a handy
way to interact with the altimeter at the field. It also operates as a portable HMI display device for the RTx/GPS system.
Please refer to the appropriate RRC3 or RTx/GPS specific sections of this manual for LCD operation and usage.

RRC3 Interface
Connecting the LCD with the RRC3
Before connecting the LCD module, be sure your altimeter is powered off, and that the USB dongle is not connected.
The LCD module connects to the altimeter via the ribbon cable included with the LCD. The connectors on the ends of the
cable are identical, and either can be connected to either device. The orientation of the cable is best determined when the
cable runs downward from the LCD, or outward from the device. The connectors are keyed, to prevent the cable from being
plugged in backwards.

After connecting the LCD, apply power to the altimeter, at which point you should hear three quick beeps from the piezo,
and the startup screen displays on the LCD. The startup screen appears similar to the following

After a few seconds, the startup screen clears, and the Home Menu is displayed.

If the display is difficult to read, you can adjust the contrast by turning the knob to the right of the cable connector on the
LCD unit. Please note that the LCD is not backlit, so it will be difficult, if not impossible, to read in poor lighting.
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Navigating the RRC3 LCD Menus
The LCD navigation is based around the four buttons on each side of the display. The center of the display shows the
subject, and by each button is an icon or word, describing the button’s action.

In the Home Menu, the top left button is used to View settings, the bottom left button shows Flight Log data, the top right
button brings up the Diagnostics menu, and the bottom right button brings up the Settings menu.
Some menus use arrows to indicate navigation. As an example, in the View Settings menu, the following may appear

In this case, the top left button will take you up one level in the menus, while the bottom left button will take you to the
next setting. The buttons on the right are not used on this menu page.

Viewing RRC3 Altimeter Settings
The current altimeter configuration for flight critical settings can be reviewed by accessing the View menu (top left button)
from the Home Menu. Note that the AUX settings cannot be viewed from this menu.

Settings are displayed two items per page, starting with the Arm and Main altitudes. Please note that some values are
displayed as a fraction of their actual value. As an example, the actual arm altitude is the value displayed times 10, and the
main altitude is the value displayed times 100.
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In this example, the RRC3 will arm once it reaches 300 feet above the pad, and the main will deploy when the rocket has
descended back down to 500 feet above the pad.
The second page is reached by pressing the next page (bottom left) button, which displays the Deployment Mode and Low
Voltage Lockout level.

Deployment Modes are defined as follows:
1. Dual Deploy Primary
2. Dual Deploy Backup
3. Apogee Only

Drogue @ Apogee / Main @ Main Deployment Altitude
Drogue @ Apogee + Drogue Delay / Main @ Deployment Altitude
Drogue @ Apogee / Main @ Apogee + 1 sec

The Low Voltage Lockout validates that the RRC3 battery voltage is above a minimum voltage level that’s appropriate for
your battery system. A setting of (2) disables this lockout feature. If this lockout feature is enabled, and the battery voltage
is at or below the specified setting, the unit will not arm itself for flight, and instead activate the POST fault code report
mode (see the POST fault codes)
Reviewing RRC3 Flight Data
Pressing the Log (lower left) button from the Home Menu allows you to review data from the Flight Log (ie. the last flight
recorded. Items are displayed two per page, as shown below:

There are a total of 8 pages of data displayed, with the first 5 providing data for the latest flight, and the last 3 providing
cumulative statistics for the altimeter. The items displayed, in order of display, are:
MaxAlt
MaxVEL
Pad
Apogee
Chute
Power On
Launch
Low
Drogue
Main
Flights

Apogee for the latest flight
Maximum velocity for the latest flight
Number of seconds between power on and liftoff
Number of seconds between liftoff and apogee
Number of seconds between apogee and the rocket reaching the ground
Altimeter bay temperature at power on
Altimeter bay temperature at liftoff
Lowest altimeter bay temperature during last flight
Average Velocity during drogue descent
Average Velocity during main descent
Total number of flights on the RRC3
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Time
AltitudeTotal

Total flight time on the RRC3
Total vertical distance up the RRC3 has travelled

Note that each item has associated “units” as established by the Audio / LCD / Telemetry Units setting. Some items also
have a superscripted “icon” to assist in interpretation:
Hourglass
Degrees
Sigma

All “Time” related items
All “Temperature” related items
All “Total” related items

Running RRC3 Diagnostics
The altimeter Diagnostics Menu can be accessed the Diag menu (top right button) from the Home Menu.

The Diagnostics Menu is split into three settings: Inputs (bottom left button), Outputs (top right button) and
Pressure/Temperature/Voltage (bottom right button).

Press the button for the diagnostics you wish to use.
Input Diagnostics
Selecting Input Diagnostics displays the state of four key inputs ‐‐ the Drogue, Main and Auxiliary continuity status, and the
state of the programming pushbutton.

In the example above, there is continuity only on the Main terminals, and the pushbutton is not pressed.
If a problem is identified, correct the issue and press the refresh (bottom left) button. Refresh causes the altimeter to scan
the inputs, and update the display. If the state begins as shown above, then the programming pushbutton is held down
while the refresh button is pressed, the display updates to match the following image.
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Likewise, connecting a match (or test light) to the Drogue terminals and pressing refresh (while no longer holding the
programming push button) results in the following display

Output Diagnostics
The Output Diagnostics allow you to verify the firing circuitry on your RRC3, as well as verify that the matches you’ve
chosen can be fired by the RRC3’s firing circuitry. If your goal is to simply test the altimeter’s output circuitry, a single
miniature Christmas Tree bulb works well ‐‐ it provides sufficient resistance for the continuity circuitry to detect it as a
charge, and will light up when the altimeter fires the output.
WARNING: Testing the outputs with pyrotechnic materials connected to the outputs will result in their ignition. USE
EXTREME CARE WHEN TESTING OUTPUTS WITH ANYTHING OTHER THAN LIGHT BULBS CONNECTED TO THE OUTPUTS.
Once you have entered the Output Diagnostics Menu, the LCD will allow you to select which output is to be tested.

Press the button associated with the output you wish to test: drogue (bottom left), main (top right), or auxiliary (bottom
right). The altimeter will then produce a series of rapid warning beeps and display the confirmation screen.

Pressing the top left button will return to the Output Diagnostics menu. Pressing the bottom left button will fire the
selected output, then return to the Output Diagnostics Menu.
Pressure/Temperature/Voltage
The Pressure/Temperature/Voltage Diagnostics allows you to monitor the ambient condition of the altimeter, but more
importantly, to get a reading of your battery’s voltage under load.
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Configuring the RRC3 Altimeter
The Settings Menu is reached by pressing the set (bottom right) button from the Home Menu.

Within the Settings Menu are three sub‐menus for three groups of functions: Base (top right button) providing access to the
most commonly used functions, Auxiliary (bottom right button) which provides control over the Auxiliary output, and
Telemetry (bottom left button) which controls the data stream fed via the on‐board com port.
All settings are modified via the same mechanism ‐‐ the altimeter displays the specific setting, as well as its current value.
To change the setting value, use the buttons on the right to increase or decrease the setting, as shown in this example

Here, the top left button maintains its function of taking you back one level, and the bottom left button navigates to the
next setting. The top right button increases the setting value, in this case the Arm Altitude, until the maximum allowed
value is reached, and the bottom right button decreases the value until the minimum allowed value is reached.
Another setting mode used for some Auxiliary configuration options uses a +1/x10 method. This is used for settings where
large values are possible, to minimize the number of button presses required.

Pressing the top‐right button will increment the displayed value by 1. Pressing the bottom‐right button will multiply the
displayed value by 10. In this case, 35 becomes 350. If the value multiplied by 10 exceeds the permissible range, the value
will revert to zero. So, starting with the display above, pressing the bottom‐right button once will change the value to 350.
Pressing it again will change it to zero.
NOTE: Always Exit Back to the SET MENU screen to ensure all your modified settings are saved to Flash Memory.
You’ll hear a double piezo blip and see the (*) character display on the left of the word SET* indicating a flash write.
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Base Settings
The meanings of the Base Settings are defined in the Base Settings section of the RRC3 User Manual. The settings are
presented in the following order
LCD Value
ARM ALT
MAIN ALT
DEPLOY MODE
AUDIO SETUP
UNITS SETUP
LV LOCK
PIEZO TONE
DROG DELAY

Setting Name
Arming Altitude
Main Deployment Altitude
Deployment Mode
Audio Options
Audio / LCD / Telemetry Units
Low Voltage Lockout Level
Piezo Tone
Drogue Delay

Auxiliary Settings
The meanings of the Auxiliary Settings are defined in the Aux Output Control Settings section of the RRC3 User Manual. The
settings are presented in the following order
LCD Value
AUX OCS
AUX TRIGGER
AUX OUTPUT
AUX TIMER
AUX COMPARE
AUX CV

Setting Name
Aux Output Control Sequence (OCS)
Aux Trigger Event
Aux Output Control Value
Aux Timer Interval
Aux Comparator Operation
Aux Comparator Value

Telemetry Settings
The Telemetry Settings are defined in the Flight Telemetry and Settings section of the RRC3 User Manual. The settings are
presented in the following order
LCD Value
TELEMETRY OPS
TELEMETRY DAT

Setting Name
Data Control
Data Items
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RTx/GPS Interface
Connecting the LCD with the RTx/GPS System
Before connecting the LCD module, be sure your unit is powered off, and that the USB dongle is not connected.
The LCD module connects to the altimeter via the ribbon cable included with the LCD. The connectors on the ends of the
cable are identical, and either can be connected to either device. The orientation of the cable is best determined when the
cable runs downward from the LCD, or outward from the device. The connectors are keyed, to prevent the cable from being
plugged in backwards

After connecting the LCD, apply power to the RTx/GPS unit. To invoke the RTx Menu, tap the PROG pushbutton on the RTx
unit during the first 5 seconds of operation. You should hear 3 quick beeps , followed by an animated splash screen. After a
few seconds, the startup screen clears, and the RTx Menu is displayed.

If the display is difficult to read, you can adjust the contrast by turning the knob to the right of the cable connector on the
LCD unit. Please note that the LCD is not backlit, so it will be difficult, if not impossible, to read in poor lighting.
Navigating the RTx/LCD Menus
The LCD navigation is based around the four buttons on each side of the display. The center of the display shows the
subject, and by each button is an icon or word, describing the button’s action.

In the RTx Menu, the top left button is used to retrieve the “Last Received Coordinates”, the bottom left button invokes a
live display of GPS Data (if the optional modules is installed), the top right button brings up the Settings menu, and the
bottom left button invokes the “Navigation” screen (using the Last Received Coordinates).
Some menus use arrows to indicate navigation. As an example, in the Settings menu, the following appears
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In this case, the top left button will take you up one level in the menus, while the bottom left button will take you to the
next setting. The buttons on the right adjust the selected setting up or down

LRC (Last Received Coordinates)
Pressing the LRC (upper right) button from the RTx Menu allows you to review the Last Received Coordinates received from
the ROCKET transmitter. These coordinates are stored to flash memory during the previous operating session of the RTx
ROCKET and BASE unit when active Radio Packets are received and decoded. The Latitude coordinate is always shown on
top, and the Longitude coordinate is always shown on the bottom and is displayed in the Lat/Lon Format you have selected.
LRC Screen

You can enter these coordinates into a Smartphone or handheld GPS unit to begin navigating to the displayed coordinates.
To exit this display, tap any of the buttons on the LCD module. You will return to the RTx Menu.
GPS (Live GPS Data Display)
Pressing the GPS (lower left) button from the RTx Menu allows you to display the output of your optionally installed BASE
GPS module. This display lets you validate and use the BASE GPS module for Lat/Lon coordinate display, along with the all
the other GPS data that’s collected and displayed. What’s shown on the GPS Screen reflects your current settings of the
LCD Update Options setting (COG and SOG values are optional). To exit this display, tap the PROG button on the RTx unit.
You will return to the RTx Menu.
GPS Lat/Lon Screen

GPS Data Screen
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NAV (Live Navigation to LRC)
Pressing the GPS (lower right) button from the RTx Menu displays the Navigation screen. This option is also dependent
upon the installation of the optional BASE GPS module. What’s shown on the NAV Screen reflects your current position
relative to the Last Received Coordinates stored in flash memory. The values on the left side of the display are the Course
and Distance to the ROCKET, and the values on the right side of the display reflect the COG of the BASE unit and the ETA
estimate to arrive at the ROCKET’s Last Received Coordinates (based on your current Speed Over Ground).

The Course and Distance to Rocket are continuously displayed. The Turn Assist Arrows, ETA, and COG (Course Over
Ground) are ONLY displayed when the BASE unit is moving, otherwise the arrows are not shown and the COG/ETA are
displayed with a question mark (?), depicting their uncertain values when stationary.
Once you’re moving with the BASE unit, use the Turn Assist arrows to turn left or right to converge your Course Over
Ground with the Course to the Rocket. When both courses/headings are within +/‐ 3 degrees of each other, the arrows will
point straight up, indicating you’re effectively heading straight toward your rocket.
To exit this display, tap the PROG button on the RTx unit. You will return to the RTx Menu.

Configuring the RTx/GPS system
The Settings are reached by pressing the set (top right) button from the RTx Menu.

All settings are modified via the same mechanism ‐‐ the LCD displays the specific setting reference, as well as its current
value. To change the setting value, use the buttons on the right to increase or decrease the setting, as shown in this
example.
Here, the top left button maintains its function of taking you back to the RTx Menu, and the bottom left button navigates to
the next setting. The top right button increases the setting value, in this case the Arm Altitude, until the maximum allowed
value is reached, and the bottom right button decreases the value until the minimum allowed value is reached.
NOTE: Always Exit Back to the RTx MENU screen to ensure all your modified settings are saved to Flash Memory.
You’ll hear a double piezo blip and see the (*) character display on the left of the word RTx* indicating a flash write.
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RTx/GPS Settings
The meanings of these RTx/GPS settings are defined in the Setting Section of the RTx/GPS User Manual. The settings are
presented in the following order
LCD Value
Epoch Trig
Unit Format
LCD Update
USB Stream
MSL Offset
Audio Ops
Piezo Tone
Low Voltage

Setting Name
Epoch Log Trigger
LCD Lat/Lon/Units Format
LCD Update Options
Streaming Format
GPS MSL Offset
Audio Operations
Piezo Tone
Low Voltage

Product Warranty
Missile Works Corporation has exercised reasonable care in the design and manufacture of this product and warrants the
original purchaser that the LCDT is free of defects and that it will operate at a satisfactory level of performance for a period
of one year from the original date of purchase. If the system fails to operate as specified, then return the unit (or units)
within the warranty period for repair or replacement (at our discretion). The system must be returned by the original
purchaser, and be free of modification or any other physical damage which renders the system inoperable. Upon repair of
replacement of the unit, Missile Works Corporation will return the unit postage‐paid to the original purchaser.

Product Disclaimer and Limit of Liability
Because the use and application of this equipment are beyond our control, the purchaser or user agrees to hold harmless
Missile Works Corporation and their agents from any and all claims, demands, actions, debts, liabilities, judgments, costs,
and attorney fees arising out of, claimed on account of, or in any manner predicated upon loss or damage to property of, or
injuries to or the death of any and all persons arising out of the use this equipment. Due to the nature of electronic devices,
and the application and environments for those devices, the possibility of failure can never be totally ruled out. It is the
responsibility of the purchaser or user of this equipment to properly test and simulate the actual conditions under which
the device is intended to be used to ensure the highest degree of reliability and success.
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